Uprog не видит С2000-Ethernet

FORUM_NAME: С2000-Ethernet
Описание: Преобразователь интерфейсов RS-485/RS-232 в Ethernet С2000-Ethernet
Справочная информация, руководства, прошивки для С2000-Ethernet
Модератор: Модераторы
Olga
Olga
Репутация: 2
Сообщения: 71
Зарегистрирован: 22.04.2013
С нами: 3 года 7 месяцев
Профессия: инженер

Непрочитанное сообщение #21 Olga » 15.10.2015, 10:22

А для UPROG тайм-аут увеличивали на вкладке RS (не по конкретным портам)?
Из документации на ПП "В режиме Орион-Slave светодиод мигает зелёным цветом (частота 0,5 Гц, скважность 2) при отсутствии обращений и загорается на 5 сек после каждого обращения." Обращали внимание, включается светодиод на ПП (и в случае с Моксой, и в случае с USB-RS485)?
Дополнительные настройки есть у USB-RS485. Например, выглядят вот так (windows 7, USB-RS485 исправно работает):
Вложения
Доп_настройки USB_RS485.png

tihonya
tihonya
Репутация: 0
Сообщения: 5
Зарегистрирован: 13.10.2015
С нами: 1 год 1 месяц
Профессия: инженер

Непрочитанное сообщение #22 tihonya » 15.10.2015, 20:09

При нахождении С2000-ПП в Rsetting диод на ПП горит постоянно в течении нескольких секунд именно в тот момент, когда Rsetting находит адрес ПП. После этого диод на ПП продолжает мигать как и до начала опроса.

Поскольку USB-RS под рукой больше не было, пришлось дальше пытаться настроить через Nport5232.
Методом "научного тыка" был установлен NPort Windows Driver Manager (WHQL certified) (скачивается с сайта Моха).
Эта софтина позволила добавить СОМ-порты в диспетчер устройств(у меня это были 3 и 4) параллельно с "виртуально-реальными" портами(у меня это были 6 и 7), создаваемыми NPort Administration Suite(в мануалках на Моха описана работа именно с ней).
Rsetting смог "достучаться" до ПП и через 3, и через 6. Uprog смог увидеть ПП только через 6 СОМ-порт.

После этого все подключения были возвращены к схеме рабочей документации (С2000М <-> С2000ПП <-> Nport5232 <-> Сервер с Uprog и OrionModbus) Настройки СОМ-портов были возвращены к начальным. Данные через ПП нормально считываются.

Lykym M
Lykym M
Репутация: 1
Сообщения: 26
Зарегистрирован: 17.12.2013
С нами: 2 года 11 месяцев
Профессия: наладчик
Откуда: Челябинск

Непрочитанное сообщение #23 Lykym » 01.12.2016, 10:11

Здравствуйте, уважаемые.
Нашел, вроде бы, решение проблемы. Снова попытался достучаться до пульта управления С2000 с помощью MOXA Uport1150 и по RS232 и по RS485, снова не получилось (((( Попробовал с помощью других преобразователей (Сапфир, Болидовский преобразователь RS485) все пошло. В общем, в RSsettings поставил галочку в чекбоксе "[SmartPI]-Не управлять приемопередатчиком" и преобразователь сразу нашелся в пипроге. Пробуйте.

Admin M
Администратор
Администратор
Аватара
Admin M
Администратор
Администратор
Возраст: 36
Репутация: 17
Сообщения: 309
Зарегистрирован: 04.06.2012
С нами: 4 года 6 месяцев
Профессия: в поисках себя
Откуда: респ. Беларусь, г. Минск

Непрочитанное сообщение #24 Admin » 04.12.2016, 08:18

Вот тема с похожей проблемой Uprog v.41054 не видит через преобразователь интерфеса от MOXA uport-1150 Сигнал-20П и таким же решением


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «С2000-Ethernet»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 1 гость

forum-bolid.ru : Отказ от ответственности