Проблемы с С2000-ethernet , в ядре опроса не могу активировать виртуальный com-port.

FORUM_NAME: С2000-Ethernet
Описание: Преобразователь интерфейсов RS-485/RS-232 в Ethernet С2000-Ethernet
Справочная информация, руководства, прошивки для С2000-Ethernet
Модератор: Модераторы
Alex2015
Автор темы
Alex2015
Автор темы
Репутация: 0
Сообщения: 2
Зарегистрирован: 29.06.2015
С нами: 2 года 11 месяцев
Профессия: Инженер

Непрочитанное сообщение #1 Alex2015 » 08.12.2015, 10:53

Доброго времени суток. У меня такая проблема. Есть следующая схема подключения: WinServer 2008(установленным по АРМ Орион Про)->локальная сеть-> C2000-Ethernet(Прозрачный режим)->C2000M(режим )->Приборы. Настроил С2000-ethernet все согласно мануалу. Настроил С2000М режим ,адреса по rs232 и 485 совпадают. в настройке com-port указал режим работы c2000-ethernet в сетевых настройках указал ip адрес и udp порт,В АБД создал нужный мне порт.используемый протокол орион про.с сервака соединяюсь по pprog нормально . но когда в ядре опроса ставлю галочку она исчезает. не знаю что делать :wo_ol:

Vse
Активный участник
Активный участник
Vse
Активный участник
Активный участник
Репутация: 21
Сообщения: 757
Зарегистрирован: 10.07.2013
С нами: 4 года 11 месяцев
Профессия: всё и сразу

Непрочитанное сообщение #2 Vse » 08.12.2015, 23:11

Уточните версию АРМ Орион Про.
Проверьте и настройте программой Settings "виртуальный" СОМ-порт = он же С2000-Ethernet.

Settings
Настройка параметров опроса приборов АРМ "Орион" и АРМ "Орион-Про"
http://bolid.ru/production/orion/po-orion/rssettings.html

iampopovdmitriy
iampopovdmitriy
Репутация: 0
Сообщения: 10
Зарегистрирован: 29.03.2016
С нами: 2 года 2 месяца
Профессия: наладчик

Непрочитанное сообщение #3 iampopovdmitriy » 30.03.2016, 08:14

Ставьте галочку, выбирайте порт, выбирайте ПИ и смотрите идет ли опрос.
Какой порт вы задали? Не занят ли он уже?

Smirnov Aleksey M
Smirnov Aleksey M
Возраст: 32
Репутация: 0
Сообщения: 4
Зарегистрирован: 24.03.2018
С нами: 2 месяца 28 дней
Профессия: __

Непрочитанное сообщение #4 Smirnov Aleksey » 24.03.2018, 18:48

Данная проблема с невозможностью активации определенного COM-порта в ядре АРМ возникает в случае использования данного COM-порта либо в сторонних программах, либо в Uprog. Если в Uprog создан виртуальный порт с тем же номером, что Вы и пытаетесь активировать в ядре АРМ, он его сразу же отключает.
Самый простой вариант решения проблемы в RSsettings в реестр прописать другой COM-порт, внести его в базу данных в АБД, после чего следует "обновить БД в Оперативной задаче" в АБД, зайти в ядро АРМ (RS ядро) и заново прописанный, нигде не занятый порт должен активироваться.
Сталкивался с такой же проблемой, методом проб и ошибок победил именно так.


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «С2000-Ethernet»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 1 гость

forum-bolid.ru : Отказ от ответственности