Сервер ОрионПро не видит C2000-ethernet

FORUM_NAME: С2000-Ethernet
Описание: Преобразователь интерфейсов RS-485/RS-232 в Ethernet С2000-Ethernet
Справочная информация, руководства, прошивки для С2000-Ethernet
Модератор: Модераторы
derevyankoal
Автор темы
derevyankoal
Автор темы
Репутация: 0
Сообщения: 2
Зарегистрирован: 25.05.2016
С нами: 6 месяцев 10 дней
Профессия: admin

Непрочитанное сообщение #1 derevyankoal » 26.05.2016, 12:03

Добрый день! Схема вроде стандартная
Сервер ОрионПро - виртуальный СОМ - С2000 ethernet - RS 485- C2000-2 (2 штуки). Не пойму где туплю.
Добавил виртуальный СОМ на сервере. Через settings настроил, прописал ip:порт. Настройки точно такие как и на других 6 портах(за исключением ip:port). К С2000-ethernet подключился по usb-RS232 . через uprog прописал ip:порт, добавил ip сервера в таблицу маршрутизации, поставил перемычку в режим pass (прозрачный). С сервера С2000-ethernet пингуется, порты открыты. Но на сервере он не опрашивается. Т.е. я устройств за ним не вижу.
Может кто подскажет, где я протупил?
Буду рад любым советам, спасибо.

Vse
Активный участник
Активный участник
Vse
Активный участник
Активный участник
Репутация: 7
Сообщения: 564
Зарегистрирован: 10.07.2013
С нами: 3 года 4 месяца
Профессия: всё и сразу

Непрочитанное сообщение #2 Vse » 26.05.2016, 12:09

derevyankoal, разверни на экран окно программы "ЯдроОпроса", и убедись, что напротив нужного СОМ-порта установлена "галочка" и нужный тип преобразователя и протокол.
Ещё необходимо корректно указывать UDP порт. Для каждого виртуального СОМ-порта он должен быть уникальным и не пересекаться с другими.(Например 40000=СОМ1,40001=СОМ2 и т.д.)

derevyankoal
Автор темы
derevyankoal
Автор темы
Репутация: 0
Сообщения: 2
Зарегистрирован: 25.05.2016
С нами: 6 месяцев 10 дней
Профессия: admin

Непрочитанное сообщение #3 derevyankoal » 26.05.2016, 13:05

В ядре смотрел. галка стоит
http://prntscr.com/b8lp33
порты у меня не 40000, а 2050,2051... и т.д. Видно сервер настраивали еще когда стандартным считался 2048.
Еще такой вопрос. когда ставлю его в прозрачный режим. ему подключение по RS232 не должно мешать? так на всякий случай спросил, уже не знаю на что грешить.

Vse
Активный участник
Активный участник
Vse
Активный участник
Активный участник
Репутация: 7
Сообщения: 564
Зарегистрирован: 10.07.2013
С нами: 3 года 4 месяца
Профессия: всё и сразу

Непрочитанное сообщение #4 Vse » 26.05.2016, 13:27

derevyankoal,
!!! неправильный тип ПИ !!! у Вас с2000 а надо "ПИ" и "Обмен с приборами" !!!!!!!!!!!!!!!!!!!!!!!!!!!!
У вас ПКУ С2000м есть в этой ветке????


1)в Ядре Опроса проверь всю ветвь СОМ-порта:
(+-"галочка")
+активация настроек ядра
+последовательные порты и их № + + + +
+ сом№1 >> +порт активен (проверь тип ПИ и протокол).

2)Временные задержки выставить программой settings, согласно расчётов из РЭ на 2000-ethernet.

3)в настройках с2000-ethernet нужно попробовать установить протокол Орион !
4)подключение по RS232: лучше отключить провод от клеммы RS232

посмотри здесь-http://forum-bolid.ru/viewtopic.php?f=44&t=2032


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «С2000-Ethernet»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 2 гостя

forum-bolid.ru : Отказ от ответственности