Помогите с написанием сценария на макроязыке

FORUM_NAME: АРМ Орион Про версии до 1.20
Описание: АРМ "Орион Про" — пакет программного обеспечения для аппаратно-программного комплекса ИСО "Орион", на котором реализуются системы охранной сигнализации, контроля и управления доступом, охранного видеонаблюдения, автоматика противопожарных систем, сопряженные с инженерными системами объектов.
Справочная информация, руководства для АРМ Орион Про версии до 1.20
Модератор: Модераторы
konstalex2006
Автор темы
konstalex2006
Автор темы
Репутация: 0
Сообщения: 3
Зарегистрирован: 22.03.2013
С нами: 3 года 8 месяцев
Профессия: инженер

Непрочитанное сообщение #1 konstalex2006 » 12.03.2014, 20:18

Подскажите пожалуйста, как правильно прописать сценарии для открытия дверей?

Имеются две системы СКУД, которые заведены на компьютер ПБ-5-ПК (сервер системы IP 192.168.0.1) и две системы пожарной сигнализации, которые заведены на компьютер PojPB5-pc( IP 192.168.0.4)
Задача, как открыть доступ (двери) в определенном здании (помещении) при получении сигнала "Пожар" от системы АПС?

Система СКУД построена на приборах С2000-2. Система АПС на Сигнал-20М. Орион-ПРО версии 1.11 sp2.

Насколько я понял, что при помощи сценариев, созданный на базе шаблонов, система работать не будет, т.к.

"АРМ «Орион Про» 1.11 последняя версия, в которой сценарии управления, а также расписание запуска сценариев управления не привязаны к Ядрам опроса. Отсюда вытекает следующая логика запуска сценариев управления:
1. Автоматический запуск сценариев управления по событиям системы:
Сценарии управления на основе шаблонов, запускаемые по определенным событиям, будут отрабатываться только в рамках Ядра опроса, зарегистрировавшего соответствующие события.
Сценарии управления, написанные на макроязыке, не имеют ограничения рамками одного Ядра опроса."

Прошу показать образец написания сценария управления на макроязыке.

konstalex2006
Автор темы
konstalex2006
Автор темы
Репутация: 0
Сообщения: 3
Зарегистрирован: 22.03.2013
С нами: 3 года 8 месяцев
Профессия: инженер

Непрочитанное сообщение #2 konstalex2006 » 19.03.2014, 21:33

Кому интересно, вот так это примерно должно было выглядеть:

Сценарий
Переменные
Перем Считыватель2;
Перем Компьютеры2;
Перем Компьютер2;
Перем РабочиеМеста2;
Перем РабочееМесто2;
Перем Считыватель1;
Перем Компьютеры1;
Перем Компьютер1;
Перем РабочиеМеста1;
Перем РабочееМесто1;
НачалоСценария


Компьютеры1 = СоздатьОбъект( "Компьютеры" );
Компьютер1 = Компьютеры1.ПолучитьПоИд(1);
РабочиеМеста1 = Компьютер1.РабочиеМеста();
РабочееМесто1 = РабочиеМеста1.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто1.Считыватели() ) Тогда
Считыватель1 = РабочееМесто1.Считыватели().ПолучитьПоИД( 897 );
Если не ПустоеЗначение( Считыватель1 ) Тогда
Считыватель1.ОткрытиеДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;

Компьютеры2 = СоздатьОбъект( "Компьютеры" );
Компьютер2 = Компьютеры2.ПолучитьПоИд(1);
РабочиеМеста2 = Компьютер2.РабочиеМеста();
РабочееМесто2 = РабочиеМеста2.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто2.Считыватели() ) Тогда
Считыватель2 = РабочееМесто2.Считыватели().ПолучитьПоИД( 795 );
Если не ПустоеЗначение( Считыватель2 ) Тогда
Считыватель2.ОткрытиеДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
КонецСценария

Этот сценарий изменился сам, после модернизации базы в версию 1.12. В 1.11 он выглядел совсем по-другому.

pet-and M
Активный участник
Активный участник
pet-and M
Активный участник
Активный участник
Возраст: 37
Репутация: 21
Сообщения: 1670
Зарегистрирован: 11.11.2012
С нами: 4 года
Профессия: инженер
Откуда: Санкт-Петербург

Непрочитанное сообщение #3 pet-and » 20.03.2014, 05:55

konstalex2006 писал(а):
Система СКУД построена на приборах С2000-2. Система АПС на Сигнал-20М. Орион-ПРО версии 1.11 sp2.

Насколько я понял, что при помощи сценариев, созданный на базе шаблонов, система работать не будет,
Во-первых: обновляйтесь, хотя бы до версии sp5.
Во-вторых: с чего это вдруг не будет работать?
konstalex2006 писал(а): Сценарии управления, написанные на макроязыке, не имеют ограничения рамками одного Ядра опроса."
Шаблонные сценарии отправляются на обработку всем ядрам опроса, самописным сценариям необходимо ядро опроса указать, сколько и какие, Ваше дело.
konstalex2006 писал(а): Прошу показать образец написания сценария управления на макроязыке.
Примеров в "Описании макроязыка сценариев Орио Про" не достаточно?

Aleksandr Paramonov
Aleksandr Paramonov
Возраст: 34
Репутация: 0
Сообщения: 36
Зарегистрирован: 26.04.2016
С нами: 7 месяцев 9 дней
Профессия: Инженер наладчик ОПС СКД
Откуда: Урал\п-ов Камчатка

Непрочитанное сообщение #4 Aleksandr Paramonov » 02.05.2016, 10:06

pet-and писал(а):Примеров в "Описании макроязыка сценариев Орио Про" не достаточно?

Да где это описание?
Кому не сложно киньте ссылку на описание макроязыка сценариев ОРИОН Scripts :ga-ze-ta;
Вода… Я пил её однажды. Она не утоляет жажды

DruG
DruG
Репутация: 18
Сообщения: 256
Зарегистрирован: 03.03.2016
С нами: 9 месяцев 2 дня
Профессия: безобразнорабочий

Непрочитанное сообщение #5 DruG » 02.05.2016, 12:41


а вообще этот файл должен быть с установленным Орионом

kurser
kurser
Возраст: 46
Репутация: 0
Сообщения: 74
Зарегистрирован: 30.10.2014
С нами: 2 года 1 месяц
Профессия: инженер
Откуда: Иркутск

Непрочитанное сообщение #6 kurser » 03.05.2016, 06:48

Я так понял система без приборов С2000(С2000М), чисто только на Орионе?

Aleksandr Paramonov
Aleksandr Paramonov
Возраст: 34
Репутация: 0
Сообщения: 36
Зарегистрирован: 26.04.2016
С нами: 7 месяцев 9 дней
Профессия: Инженер наладчик ОПС СКД
Откуда: Урал\п-ов Камчатка

Непрочитанное сообщение #7 Aleksandr Paramonov » 03.05.2016, 09:49

Не понял вопрос...
Это язык для написания сценария на АРМе. При чем тут аппаратный уровень? Там Pprog всеми этими делами занимается и структура построения сценария совсем другая.
Вода… Я пил её однажды. Она не утоляет жажды

DruG
DruG
Репутация: 18
Сообщения: 256
Зарегистрирован: 03.03.2016
С нами: 9 месяцев 2 дня
Профессия: безобразнорабочий

Непрочитанное сообщение #8 DruG » 03.05.2016, 13:13

он к тому что сценарий из АРМа всё равно не передаётся в С2000М и если связь с компом потерялась то и сценарии тоже потерялись

Aleksandr Paramonov
Aleksandr Paramonov
Возраст: 34
Репутация: 0
Сообщения: 36
Зарегистрирован: 26.04.2016
С нами: 7 месяцев 9 дней
Профессия: Инженер наладчик ОПС СКД
Откуда: Урал\п-ов Камчатка

Непрочитанное сообщение #9 Aleksandr Paramonov » 03.05.2016, 23:42

хм... При интеграции настроек из АРМ в пульт такая каша получается. Там без ручной корректировки никак не обойтись. Нет, ну понятно, что pprog не всемогущ, для того и АРМ придумали. Однако же при творческом подходе можно и на аппаратном уровне довольно сложные задачи решать. Там одними шагами сценария можно шатл запустить.
Вода… Я пил её однажды. Она не утоляет жажды


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «АРМ Орион Про версии до 1.20»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 4 гостя
Боты: Yandex [Bot]

forum-bolid.ru : Отказ от ответственности