Сценарий открытия дверей

FORUM_NAME: АРМ Орион Про версии до 1.20
Описание: АРМ "Орион Про" — пакет программного обеспечения для аппаратно-программного комплекса ИСО "Орион", на котором реализуются системы охранной сигнализации, контроля и управления доступом, охранного видеонаблюдения, автоматика противопожарных систем, сопряженные с инженерными системами объектов.
Справочная информация, руководства для АРМ Орион Про версии до 1.20
Модератор: Модераторы
Produx
Автор темы
Produx
Автор темы
Репутация: 0
Сообщения: 38
Зарегистрирован: 28.04.2015
С нами: 1 год 7 месяцев
Профессия: Инженер

Непрочитанное сообщение #1 Produx » 05.05.2015, 12:39

Помогите пожалуйста, следующая ситуация:
Надо создать сценарий, что-бы при нажатии комбинации клавиш, открывались все двери.
Но вот сам вопрос, везде в документациях написано, что надо создать сценарий открытия свободного доступа и нажать кнопку добавить шаг сценария, у меня таких кнопок нет, либо версия старая, либо Болид гавно, есть возможность написать сценарий руками с помощью микрокоманд, но примеры команд ни где не смог найти, ни на диске не в инете, в ТП как всегда послали куда то очень далеко. Если есть у кого примеры команд, буду очень благодарен, я так понял должно все начинаться:
Сценарий
Начало сценария
Открытие общего доступа
Считыватель 1.12.2
1.15.2
1.11.2
Конецсценария

Vse
Активный участник
Активный участник
Vse
Активный участник
Активный участник
Репутация: 8
Сообщения: 565
Зарегистрирован: 10.07.2013
С нами: 3 года 5 месяцев
Профессия: всё и сразу

Непрочитанное сообщение #2 Vse » 05.05.2015, 14:37

Источник: х:\BOLID\ARM_ORION_PRO1_12_2\DOC\SCRIPTS\10__open_doors.txt

// Выдача звукового сообщения на все приборы и открытие
// свободного доступа через все двери

// На приборы подается команда о тройном звуковом
// сигнале

Сценарий
Переменные
Перем Приборы1;
Перем Прибор1;
Перем Считыватели1;
Перем Считыватель1;
Перем Счетчик1;
НачалоСценария
Приборы1 = СоздатьОбъект("Приборы");
Если Не ПустоеЗначение( Приборы1 ) Тогда
Для Счетчик1 = 0 По Приборы1.Количество() - 1 Цикл
Если Не ПустоеЗначение( Приборы1.Элемент( Счетчик1 ) - 1 ) Тогда
Прибор1 = Приборы1.Элемент( Счетчик1 );

Прибор1.ВыдачаЗвуковогоСообщения( 3 );
КонецЕсли;
КонецЦикла;
КонецЕсли;

Считыватели1 = СоздатьОбъект("Считыватели");
Если Не ПустоеЗначение( Считыватели1 ) Тогда
Для Счетчик1 = 0 По Считыватели1.Количество() - 1 Цикл
Если Не ПустоеЗначение( Считыватели1.Элемент( Счетчик1 ) ) Тогда
Считыватель1 = Считыватели1.Элемент( Счетчик1 );

Считыватель1.ОткрытиеДоступ();
КонецЕсли;
КонецЦикла;
КонецЕсли;

КонецСценария

Produx
Автор темы
Produx
Автор темы
Репутация: 0
Сообщения: 38
Зарегистрирован: 28.04.2015
С нами: 1 год 7 месяцев
Профессия: Инженер

Непрочитанное сообщение #3 Produx » 05.05.2015, 15:31

Запустил на сервере АБД там отображаются шаги сценария, создал новый сценарий, только почему то он не работает, по какой хронологии надо его делать:
Запуск сценария
Открытие доступа (выбор считывателя на выход)
Запуск сценария
Открытие доступа
Так получается, если да, то почему то не работает


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «АРМ Орион Про версии до 1.20»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 3 гостя

forum-bolid.ru : Отказ от ответственности