ошибка №6

FORUM_NAME: АРМ Орион Про версии до 1.20
Описание: АРМ "Орион Про" — пакет программного обеспечения для аппаратно-программного комплекса ИСО "Орион", на котором реализуются системы охранной сигнализации, контроля и управления доступом, охранного видеонаблюдения, автоматика противопожарных систем, сопряженные с инженерными системами объектов.
Справочная информация, руководства для АРМ Орион Про версии до 1.20
Модератор: Модераторы
stgrin M
Автор темы
stgrin M
Автор темы
Репутация: 0
Сообщения: 26
Зарегистрирован: 02.02.2013
С нами: 3 года 10 месяцев
Профессия: инженер по обслуживанию ОПС

Непрочитанное сообщение #1 stgrin » 18.03.2013, 09:07

Здравствуйте, уважаемые специалисты!
Установил "Орион-Про" 1.12, при запуске оболочки появляется окно с ошибкой: "Ошибка №6. Приложению не удалось запуститься. Не установлен Microsoft Speach Platform." Понятно, что не запускается модуль речевого оповещения. Вручную были установлены компоненты в следующей последовательности: SpeechPlatformRuntime_x64.msi, MSSpeech_TTS_ru-RU_Elena.msi, MSSpeech_SR_ru-RU_TELE.msi, но ошибка так и не исчезла. ОС - Windows 7 Professional X64. Подскажите что неправильно делаю.

MadHacker M
Активный участник
Активный участник
Аватара
MadHacker M
Активный участник
Активный участник
Возраст: 26
Репутация: 6
Сообщения: 744
Зарегистрирован: 28.05.2012
С нами: 4 года 6 месяцев
Профессия: Программист
Откуда: МО г. Королёв

Непрочитанное сообщение #2 MadHacker » 18.03.2013, 09:17

Установите x86 версию SpeechPlatformRuntime. Дистрибутив можно найти в каталоге <каталог с Орион ПРО>\data\MSSpeachPlatform\SpeechPlatformRuntime.msi

grand_dizel
grand_dizel
Репутация: 0
Сообщения: 1
Зарегистрирован: 28.11.2014
С нами: 2 года
Профессия: сисадмин

Непрочитанное сообщение #3 grand_dizel » 28.11.2014, 18:02

вдруг кому пригодится...

если на windows xp или подобный не будет ставиться microsoft Speech Platform, проверьте какой у вас стоит NET Framework после установки NET Framework3.5 и поверх него до кучи NET Framework 4.0 всё установилось без проблем, а до этого ставиться не хотела...

MadHacker M
Активный участник
Активный участник
Аватара
MadHacker M
Активный участник
Активный участник
Возраст: 26
Репутация: 6
Сообщения: 744
Зарегистрирован: 28.05.2012
С нами: 4 года 6 месяцев
Профессия: Программист
Откуда: МО г. Королёв

Непрочитанное сообщение #4 MadHacker » 28.11.2014, 18:06

Достаточно 3.5.
microsoft Speech Platform официально поддерживается начиная с Vista.
По факту спокойно ставится на XP, но ему нужен .NET.
Самое смешное, что .NET ему нужен только для установки (не для работы). Инсталлятор написан так, что пытается зарегистрировать библиотеку для .NET используя функции .NET добавленные только с третьей версии.

В документации кстати должно быть написано, что для установки на XP нужен .net.


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «АРМ Орион Про версии до 1.20»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 6 гостей

forum-bolid.ru : Отказ от ответственности